
  






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.fortbendstar.com/content/tncms/live/" />
<meta name="tncms-access-version" content="" />
<meta name="keywords" content="sports" />
<meta name="news_keywords" content="sports" />
<meta name="description" content="The Marshall Buffalos&rsquo; track team has a recent, but extensive, history of dominance in the region and state. Its boys&rsquo; team has taken home the Class 5A state championship five" />
<meta name="author" content="Landan Kuhlmann LKuhlmann@fortbendstar.com" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="fzmhwRc7ZjVG1MXycVySc-Qu6koqSsY6y5Urvb0B2oA" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?crop=1070%2C562%2C0%2C20&amp;resize=1070%2C562&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1070" />
<meta property="og:image:height" content="562" />
<meta property="og:title" content="Buffs boys, girls thunder through area meets" />
<meta property="og:description" content="The Marshall Buffalos&rsquo; track team has a recent, but extensive, history of dominance in the region and state. Its boys&rsquo; team has taken home the Class 5A state championship five" />
<meta property="og:site_name" content="Fort Bend Star" />
<meta property="og:section" content="Sports" />
<meta name="twitter:image" content="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?crop=1070%2C562%2C0%2C20&amp;resize=438%2C230&amp;order=crop%2Cresize" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@FortBendStar" />
<meta name="twitter:image:alt" content="Marshall track" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.c58a1beaa3640fa94c3db09673c4d95c.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.a3e7acf647b637568b6de9dcf43c4906.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.e130daca08ae73d027cf86da7acde398.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans&amp;display=swap"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Archivo+Narrow:400,500,600,700|Open+Sans|PT+Seri|Droid+Serif:300,400,600,700&amp;display=swap"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>/*<![CDATA[*/ #user-controls-1000602 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1000602 .tn-user-screenname, #user-controls-1000602 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1000602 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1000602 .dropdown-signup { font-size: 12px; } #user-controls-1000602 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1000602 .large-user-avatar { margin-right: 10px; } #user-controls-1000602 .large-user-controls { font-size: 12px; } #user-controls-1000602 .logout-btn { cursor: pointer; } #user-controls-1000602 .login-btn { color: #fff!important; } #user-controls-1000601 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1000601 .tn-user-screenname, #user-controls-1000601 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1000601 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1000601 .dropdown-signup { font-size: 12px; } #user-controls-1000601 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1000601 .large-user-avatar { margin-right: 10px; } #user-controls-1000601 .large-user-controls { font-size: 12px; } #user-controls-1000601 .logout-btn { cursor: pointer; } #user-controls-1000601 .login-btn { color: #fff!important; } #tncms-block-1000569 .tnt-prop-img { max-width: 700px; } #site-logo-1000569 { color: #666; } #tncms-block-1000594 .tnt-prop-img { max-width: 700px; } #site-logo-1000594 { color: #666; } #block-1000597 .search-spinner { position: absolute; } #block-1000597 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1000597-dropdown .dropdown-menu { padding: 15px; width: 400px; font-weight: normal; } @media screen and (max-width: 991px) { #site-search-1000597-dropdown .dropdown-toggle { display: none; } #main-navigation .navbar-left { clear: both; } #site-search-1000597-dropdown .pull-right { float: none!important; } #site-search-1000597-dropdown .dropdown-menu { display: block; position: static; float: none; width: auto; margin-top: 0; background-color: transparent; border: 0; box-shadow: none; border-radius: 0; border-bottom: 1px solid rgba(0,0,0,0.1); } } @media screen and (min-width: 320px) { #ad-1000704 { min-height: 250px; min-width: 300px; } } @media screen and (min-width: 768px) { #ad-1000704 { min-height: 250px; min-width: 300px; } } @media screen and (min-width: 992px) { #ad-1000704 { min-height: 250px; min-width: 300px; } } @media screen and (min-width: 1200px) { #ad-1000704 { min-height: 250px; min-width: 300px; } } #block-1000533 .card.summary { border: 0; padding: 0; margin: 0; } #block-1000533 .card-panel { background-color: #ffffff; border-color: rgba(0,0,0,.08); } #block-1000570 .most-popular .tab-text { display: none; } #block-1000570 .most-popular .active .tab-text { display: inline; } #tncms-block-1027930 .tnt-prop-img { max-width: 317px; } #tncms-block-1033033 .tnt-prop-img { max-width: 488px; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.61.6"},"crm":{"group_id":"800"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"banded","style":"default","path":"\/sports","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"type":"article","author":"Landan Kuhlmann\nLKuhlmann@fortbendstar.com","start_hour":"20","id":"4de54afa-c434-11ec-a452-07036ac0d637","app":"editorial","ga_page":"\/sports\/article_4de54afa-c434-11ec-a452-07036ac0d637.html"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":224},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-188368234-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="module" async="async" src="/shared-content/art/tncms/api/access.js"></script>
<script src="/shared-content/art/tncms/api/access-legacy.js" defer="defer" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.d6d18fcf88750a16d256e72626e676a6.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.08a61544f369cc43bf02e71b2d10d49f.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.f3739bd4d04bcee9e077d20b4f31f29c.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.cb897187c4718280fd69d2e6d6c3909d.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.7a9170240d21440159b9bd59db72933b.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.283bfb49ef55c073fceda15ffbf58de8.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/search/resources/scripts/tnt.followed.notifications.6600e99595fd219e961e9882c796e61c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};

    __tnt.ads.dfp.targeting.asset_id = '4de54afa-c434-11ec-a452-07036ac0d637';
    __tnt.ads.dfp.targeting.k = ["sports"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        cube:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/cube.d862aac30e9cb24516c7474509403c47.js",
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/interstitial.df40f87de692498682823c6773da5459.js",
        nativeArticle:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/paw.9ea074ccc913cb273a4b790e1e37460a.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/pencil.2662e4159cdac4809283c5399d78644b.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        roller:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/roller.c699c542afb9f08b38613e8473ddf14f.js",
        slider:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/slider.015001bff591d1665c6d0ec2a888b1ca.js",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/fortbendstar.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/22186434474/22186434474/fortbendstar.com/sports';
            
                gptAdSlots['ad-1000704'] = googletag.defineSlot(adUnit, [300,250], 'ad-1000704').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.pop();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Buffs boys, girls thunder through area meets | Sports | fortbendstar.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #efefef; } .fixed-nav #main-navigation { background-color: #efefef !important; } #site-top-nav-container, #site-top-nav { background-color: #efefef; } #site-footer-container, #site-footer { background-color: #231f20; color: #efefef; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus, .navbar-default .navbar-nav>li>button.nav-link, .navbar-default .navbar-nav>li>button.nav-link:hover, .navbar-default .navbar-nav>li>button.nav-link:focus, .navbar-default .navbar-nav>.open>button.nav-link, .navbar-default .navbar-nav>.open>button.nav-link:hover, .navbar-default .navbar-nav>.open>button.nav-link:focus{ color: #231f20; } .navbar-toggle .icon-bar { background-color: #231f20 !important; } .navbar-toggle .sr-only-show { color: #231f20 !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-bottom-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #231f20; } }#site-copyright a, #site-footer a { color: #efefef; }.search-redesign .top-breakout > .row { max-width: 1200px; }.nav-tabs>li.active>a, .nav-tabs>li.active>a:hover, .nav-tabs>li.active>a:focus { border-top-color: #515151; }#site-header-container{ border-bottom: 3px solid #515151; }#site-footer-container{ border-top: 3px solid #515151; } .tnt-bg-accent { background-color: #515151; } a .tnt-caret-down { color: #515151; } .block-title .block-title-inner { border-color: #515151; } a.thumbnail:hover, a.thumbnail:focus, a.thumbnail.active { border-color: #515151; } .form-control:focus { border-bottom-color: #515151; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here font-family: 'Archivo Narrow', sans-serif; font-family: 'Open Sans', sans-serif; font-family: 'PT Serif', serif; */ .user-controls .btn-link {color: #00b8f1;} #site-top-nav-container li a:hover { color: #00b8f1 !important; } #topbar-col-one-nav_menu { padding-left: 60px; } #topbar-col-one-nav_menu { padding-left: 60px; text-transform: uppercase; font-size: 12px; } #site-top-nav-container li a {color:#231f20!important;} .navbar-brand img {margin-top: -23px;} .header-search .btn {color:#231f20;} #site-navbar-container.affix {box-shadow: rgba(0, 0, 0, 0.25) 0px 10px 6px -6px;} #site-navbar-container.affix .navbar-brand img {margin-top: -15px;} #main-navigation li a { font-family: 'Archivo Narrow', sans-serif; font-size: 19px; font-weight:600; } #main-navigation li a:hover {color:#00b8f1;background:transparent;/*text-shadow: -1px -1px 0px rgba(0,0,0,0.50);*/} /* .dropdown-menu > li > a, .dropdown-menu > li > a:hover {text-shadow: none!important;} */ .nav > li > a {padding: 10px 10px;} .navbar-header .navbar-brand {height: 50px} .navbar-header .navbar-brand .img-responsive {max-height: 85px} #site-navbar-container, #main-navigation {background-color: #efefef;height: 50px;} .block-title h1, .block-title h2, .block-title h3, .block-title h4, .block-title h5, .block-title h6 { font-family: 'Droid Serif', serif; color:#000000; } .btn-primary { color: #fff!important; background-color: #00b8f1; border-color: #00b8f1; } .btn-primary:hover {background-color: #231f20;} .tnt-asset-link.read-more-link { text-transform: lowercase; font-weight: normal; } .card-headline a {font-family: 'Droid Serif', serif;} .card-headline a:hover {color: #231f20 !important;} #site-footer-container { border-top: none; } /* mobile header */ #tncms-block-1000594 .tnt-prop-img { max-width: 260px; } .navbar-brand img { margin-top: -13px; } /* Ticket #849724 */ .business-cover { background-image: none; } .business-cover-color { background-color: #ffffff !important; } </style>
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="Buffs boys, girls thunder through area meets | Sports | fortbendstar.com" href="http://www.fortbendstar.com/search/?f=rss&amp;t=article&amp;c=sports&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.46a248d75dc687aa8d928092f6b77fc7.js"></script>
                
    <!--Uncomment and edit to add Google Fonts--><script language="javascript" type="text/javascript">
$(document).ready(function() {       
      $('.header-search .btn').html('<i class="fas tnt-search" aria-hidden="true"></i>');
        

}); 
</script>    

<head>
<!-- SCRIPT TO INSERT IN HEAD -->
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</head>

    

        </head>
        <body class="fixed-scroll-nav app-editorial grid-banded blox-asset uuid-4de54afa-c434-11ec-a452-07036ac0d637  section-sports type-article infinity-disabled" data-authors='[]' data-path="/sports">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.fortbendstar.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.61.6&amp;townnews.crm.group_id=800&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=banded&amp;tncms.page.style=default&amp;tncms.page.path=%2Fsports&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.type=article&amp;tncms.asset.author=Landan+Kuhlmann%0ALKuhlmann%40fortbendstar.com&amp;tncms.asset.start_hour=20&amp;tncms.asset.id=4de54afa-c434-11ec-a452-07036ac0d637&amp;tncms.asset.app=editorial&amp;tncms.asset.ga_page=%2Fsports%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=224&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-188368234-1&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        <a href="#main-page-container" class="sr-only" onclick="document.getElementById('main-page-container').scrollIntoView(); return false">Skip to main content</a>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-contribute-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-certificate tnt-fw"></i></div>
                <div class="asset-edit-message">You are the owner of this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" href="https://www.fortbendstar.com/users/admin/contribute/article/?assetid=4de54afa-c434-11ec-a452-07036ac0d637&assettype=article"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit Article</a>
                    
                        <a class="btn btn-danger btn-sm" href="https://www.fortbendstar.com/users/admin/contribute/article/?from_section=/sports"><i class="fas tnt-plus tnt-fw"></i> Add New Article</a>
                    
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.fortbendstar.com/tncms/admin/editorial-asset/?edit=4de54afa-c434-11ec-a452-07036ac0d637"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left visible-sm visible-xs" aria-label="Left Main Menu" aria-expanded="false" tabindex="-1" >
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1000602" class="tncms-block hidden-md hidden-lg"><div id="user-controls-1000602" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.fortbendstar.com/users/signup/?referer_url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.fortbendstar.com/users/login/?referer_url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.fortbendstar.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1000602').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.fortbendstar.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.fortbendstar.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.fortbendstar.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-1000602').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.fortbendstar.com/users/logout/" id="user-logout-form-1000602"><input type="hidden" name="referer_url" value="https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/community/"  class="nav-link tnt-section-community ">Community</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/countynews/"  class="nav-link tnt-section-county-news ">County News</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/countynews/meadows_place/"  class="nav-link tnt-section-meadows-place">Meadows Place</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/countynews/missouri_city/"  class="nav-link tnt-section-missouri-city">Missouri City</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/countynews/richmond/"  class="nav-link tnt-section-richmond">Richmond</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/countynews/rosenberg/"  class="nav-link tnt-section-rosenberg">Rosenberg</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/countynews/stafford/"  class="nav-link tnt-section-stafford">Stafford</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/countynews/sugar_land/"  class="nav-link tnt-section-sugar-land">Sugar Land</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/culture/"  class="nav-link tnt-section-culture ">Culture</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/culture/restaurant_reviews/"  class="nav-link tnt-section-restaurant-reviews">Restaurant Reviews</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><span tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </span><a tabindex="-1" aria-hidden="true" href="/sports"  class="nav-link tnt-section-sports ">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/high_schools/"  class="nav-link tnt-section-high-schools">High Schools</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/sugar_land_skeeters/"  class="nav-link tnt-section-sugar-land-skeeters">Sugar Land Skeeters</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/schoolnews/"  class="nav-link tnt-section-school-news ">School News</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/business_real_estate/"  class="nav-link tnt-section-business-real-estate ">Business & Real Estate</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/health/"  class="nav-link tnt-section-health ">Health</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion ">Opinion</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/marketplace/"  class="nav-link tnt-section-business-directory ">Business Directory</a>
                        </div>
                    </div></div></div></div>
                
                
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li>
                <a class="nav-link    tnt-section-about-us"  href="/site/about.html"  tabindex="0" >
                    <span class="nav-label ">About Us</span>
                </a></li><li>
                <a class="nav-link    tnt-section-contact-us"  href="https://www.fortbendstar.com/site/forms/contact_us/"  target="_blank" rel="noopener" tabindex="0" >
                    <span class="nav-label ">Contact Us</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-1000601" class="tncms-block user-controls"><div id="user-controls-1000601" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li>
                    <a href="https://www.fortbendstar.com/users/signup/?referer_url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">
                        Sign Up
                    </a>
                </li><li>
                    <a href="https://www.fortbendstar.com/users/login/?referer_url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li>
                        <a href="https://www.fortbendstar.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">
                            Dashboard
                        </a>
                    </li>
                    <li>
                        <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1000601').submit(); return false;" rel="nofollow">
                            Logout
                        </a>
                    </li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.fortbendstar.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.fortbendstar.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.fortbendstar.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem">
                        <a class="logout-btn" onclick="document.getElementById('user-logout-form-1000601').submit(); return false;" rel="nofollow">
                        <i class="fas tnt-sign-out-alt tnt-fw"></i> Logout
                        </a>
                    </li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.fortbendstar.com/users/logout/" id="user-logout-form-1000601"><input type="hidden" name="referer_url" value="https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "><div id="tncms-block-1000569" class="tncms-block center-block"><div id="site-logo-1000569" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=200%2C39" 
            srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=150%2C29 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=200%2C39 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=225%2C43 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=300%2C58 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=400%2C77 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=540%2C104 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg?resize=640%2C123 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/c5cea918-5459-11eb-b69b-eb50e6edcbdf.jpg 750w"
            sizes="(min-width: 1200px) 1140px, calc(100vw - 30px)"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="700"
            height="135"
            alt="site-logo"
            ></a>
        </div></div></div></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-9 col-sm-9"><div id="tncms-region-masthead-col-two" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" aria-label="Main" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" visible-sm visible-xs navbar-toggle pull-left" data-toggle="offcanvas" data-target="left" aria-label="Left Main Menu" aria-expanded="false">
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            
                        </button>
                         
                    
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1000594" class="tncms-block"><div id="site-logo-1000594" class="site-logo-container text-left" ><div class="logo-middle">
            <a  href="/" aria-label="Home page"><img 
            
            src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=200%2C39" 
            srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=150%2C29 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=200%2C39 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=225%2C43 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=300%2C58 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=400%2C77 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=540%2C104 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg?resize=640%2C123 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/4f9c0742-1fb4-11eb-b69b-3f47bdc27cf4.jpg 750w"
            sizes="100vw"
            
            class=" img-responsive lazyload tnt-prop-img"
            width="700"
            height="135"
            alt="site-logo"
            ></a>
        </div></div></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown" aria-label="Search">
                                    <span class="fas tnt-search"></span>
                                </a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." title="Site Search" class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });
                        </script>
                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1000597" class="tncms-block header-search"><ul id="site-search-1000597-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown" aria-label="Search">
                <span class="fas tnt-search"></span>
            </a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1000597" aria-label="Site search" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div id="site-search-form-1000597" class="site-search-form input-group pull-right normal ">
        <label for="site-search-1000597-term" class="sr-only">Site search</label>
        <input id="site-search-1000597-term" name="q" title="Site search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1000597-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	            
                <span id="site-search-button-1000597" class="hidden-xs hidden-sm ">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link    tnt-section-community"  href="/community/"  tabindex="0" >
                    <span class="nav-label ">Community</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-county-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/countynews/"  tabindex="0" >
                    <span class="nav-label ">County News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-meadows-place"  href="/countynews/meadows_place/"  tabindex="0" >
                    <span class="nav-label ">Meadows Place</span>
                </a></li><li>
                <a class="nav-link    tnt-section-missouri-city"  href="/countynews/missouri_city/"  tabindex="0" >
                    <span class="nav-label ">Missouri City</span>
                </a></li><li>
                <a class="nav-link    tnt-section-richmond"  href="/countynews/richmond/"  tabindex="0" >
                    <span class="nav-label ">Richmond</span>
                </a></li><li>
                <a class="nav-link    tnt-section-rosenberg"  href="/countynews/rosenberg/"  tabindex="0" >
                    <span class="nav-label ">Rosenberg</span>
                </a></li><li>
                <a class="nav-link    tnt-section-stafford"  href="/countynews/stafford/"  tabindex="0" >
                    <span class="nav-label ">Stafford</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sugar-land"  href="/countynews/sugar_land/"  tabindex="0" >
                    <span class="nav-label ">Sugar Land</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-culture"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/culture/"  tabindex="0" >
                    <span class="nav-label ">Culture</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-restaurant-reviews"  href="/culture/restaurant_reviews/"  tabindex="0" >
                    <span class="nav-label ">Restaurant Reviews</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link   dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link    tnt-section-high-schools"  href="/sports/high_schools/"  tabindex="0" >
                    <span class="nav-label ">High Schools</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sugar-land-skeeters"  href="/sports/sugar_land_skeeters/"  tabindex="0" >
                    <span class="nav-label ">Sugar Land Skeeters</span>
                </a></li></ul></li><li>
                <a class="nav-link    tnt-section-school-news"  href="/schoolnews/"  tabindex="0" >
                    <span class="nav-label ">School News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-business-real-estate"  href="/business_real_estate/"  tabindex="0" >
                    <span class="nav-label ">Business & Real Estate</span>
                </a></li><li>
                <a class="nav-link    tnt-section-health"  href="/health/"  tabindex="0" >
                    <span class="nav-label ">Health</span>
                </a></li><li>
                <a class="nav-link    tnt-section-opinion"  href="/opinion/"  tabindex="0" >
                    <span class="nav-label ">Opinion</span>
                </a></li><li>
                <a class="nav-link    tnt-section-business-directory"  href="/marketplace/"  tabindex="0" >
                    <span class="nav-label ">Business Directory</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        <div class="visible-xs pull-right article-share-nav" style="background-color: #efefef">
            <span>Share This <i class="fas tnt-arrow-right"></i></span>
            <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&via=FortBendStar&url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.fortbendstar.com/tncms/asset/editorial/4de54afa-c434-11ec-a452-07036ac0d637" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BFort%20Bend%20Star%5D%20Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&body=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul>
        </div>
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-1029161" class="tncms-block"><script>
document.addEventListener("DOMContentLoaded",function(){
var links = ["https://www.artcolonyassociation.org/","https://staffingfortexans.com/get-started/","https://www.clinicalstudyfinder.com/back-pain","mailto:jerry@dreamhomesbyjerry.com","https://charltonsbodyrepair.com"];
var images = ["https://www.fortbendstar.com/tncms/media/bayouart/","https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/media/8/c8/8c8f8cb0-b4eb-11eb-abd5-73b6d7965954/609ed10554bb4.image.jpg","https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/media/e/fa/efa3f586-92a7-11eb-82d9-83e2938a52d1/606554b2404c1.image.png","https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/media/e/bb/ebb4bf06-8379-11eb-8728-83cc4100498f/604bdd0b5aa58.image.jpg?resize=750%2C100","https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/media/e/0d/e0db2ca0-8379-11eb-9921-cb999c0ea962/604bdcf9290ef.image.jpg?resize=750%2C100"];
var incr = 0;
var renew = setInterval(function(){
if(links.length == incr){
incr = 0;
}
else {
document.getElementById("bannerImage").setAttribute("src",images[incr]);
document.getElementById("bannerLink").setAttribute("href",links[incr]);
incr++;
}
},
5000);
}
);

</script><div class="text-center mb-4">
<a id="bannerLink" href="https://www.artcolonyassociation.org/">
<img id="bannerImage" src="https://www.fortbendstar.com/tncms/media/bayouart/" class="img-responsive center-block" alt="ad"></a>
</div>
<div><img src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/media/9/c0/9c0c52be-837b-11eb-b1cb-7b0e46e1248a/604bdfe0aff38.image.jpg"></div></div></div></div>
        </div><div id="modal-image-b517e84a-c434-11ec-b642-dbe6ebcab48a" class="modal fullscreen in modal-image image-default modal-b517e84a-c434-11ec-b642-dbe6ebcab48a" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                <img
                        src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=400%2C225"
                        srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=990%2C557 990w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=1035%2C582 1035w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=1070%2C602 1200w"
                        sizes="100vw"
                        
                        width="1070"
                        height="602"
                        alt="Marshall track"
                        class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-b517e84a-c434-11ec-b642-dbe6ebcab48a" data-target=".caption-inner-modal-image-b517e84a-c434-11ec-b642-dbe6ebcab48a">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-b517e84a-c434-11ec-b642-dbe6ebcab48a collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">Contributed photo</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.fortbendstar.com%2Fmarshall-track%2Fimage_b517e84a-c434-11ec-b642-dbe6ebcab48a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/marshall-track/image_b517e84a-c434-11ec-b642-dbe6ebcab48a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b517e84a-c434-11ec-b642-dbe6ebcab48a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Marshall%20track&via=FortBendStar&url=https%3A%2F%2Fwww.fortbendstar.com%2Fmarshall-track%2Fimage_b517e84a-c434-11ec-b642-dbe6ebcab48a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/marshall-track/image_b517e84a-c434-11ec-b642-dbe6ebcab48a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b517e84a-c434-11ec-b642-dbe6ebcab48a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.fortbendstar.com/marshall-track/image_b517e84a-c434-11ec-b642-dbe6ebcab48a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/marshall-track/image_b517e84a-c434-11ec-b642-dbe6ebcab48a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b517e84a-c434-11ec-b642-dbe6ebcab48a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.fortbendstar.com/tncms/asset/editorial/b517e84a-c434-11ec-b642-dbe6ebcab48a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b517e84a-c434-11ec-b642-dbe6ebcab48a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BFort%20Bend%20Star%5D%20Marshall%20track&body=https%3A%2F%2Fwww.fortbendstar.com%2Fmarshall-track%2Fimage_b517e84a-c434-11ec-b642-dbe6ebcab48a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b517e84a-c434-11ec-b642-dbe6ebcab48a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/marshall-track/image_b517e84a-c434-11ec-b642-dbe6ebcab48a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b517e84a-c434-11ec-b642-dbe6ebcab48a"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-b517e84a-c434-11ec-b642-dbe6ebcab48a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="b517e84a-c434-11ec-b642-dbe6ebcab48a" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="b517e84a-c434-11ec-b642-dbe6ebcab48a" class="save-list-b517e84a-c434-11ec-b642-dbe6ebcab48a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="b517e84a-c434-11ec-b642-dbe6ebcab48a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-b517e84a-c434-11ec-b642-dbe6ebcab48a img { max-height: 602px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-4de54afa-c434-11ec-a452-07036ac0d637" class="asset article-default"  data-url="https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="The Marshall Buffalos’ track team has a recent, but extensive, history of dominance in the region and state. Its boys’ team has taken home the Class 5A state championship five of the last seven seasons, while its girls’ team is on the heels of its first state crown. "/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?crop=1070%2C562%2C0%2C20&resize=1070%2C562&order=crop%2Cresize">
            <meta itemprop="width" content="1070">
            <meta itemprop="height" content="562">
        </div>
        <meta itemprop="name" content="fortbendstar.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" />
    <style>
                .asset-paging .direction {
                    color: #515151;
                }
            </style><div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.fortbendstar.com\/tncms\/search\/mlt\/?origin=4de54afa-c434-11ec-a452-07036ac0d637&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"4de54afa-c434-11ec-a452-07036ac0d637","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-4de54afa-c434-11ec-a452-07036ac0d637" class="asset-paging">
                <div id="paging-prev-4de54afa-c434-11ec-a452-07036ac0d637" class="paging-link prev offset"></div>
                <div id="paging-next-4de54afa-c434-11ec-a452-07036ac0d637" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    <div class="tow-wrapper no-flags">
        
        
    </div>
    <h1 itemprop="headline" class="headline">
        <span>
            
            Buffs boys, girls thunder through area meets
        </span>
    </h1>
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span id="author-popup-f97faa20-56dc-11eb-b69b-335477e091b2-asset-4de54afa-c434-11ec-a452-07036ac0d637" class="tnt-byline asset-byline" rel="popover" itemprop="author"><a href="https://www.fortbendstar.com/users/profile/Landan%20Kuhlmann">By Landan Kuhlmann
LKuhlmann@fortbendstar.com</a></span>
                
                    <div id="author-popup-f97faa20-56dc-11eb-b69b-335477e091b2-asset-4de54afa-c434-11ec-a452-07036ac0d637-content" class="hide">
                        <article class="clearfix card author popup-content card-author-f97faa20-56dc-11eb-b69b-335477e091b2">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.fortbendstar.com/users/profile/Landan%20Kuhlmann" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="Landan Kuhlmann" src="https://secure.gravatar.com/avatar/303468b57b38acf6e3640ece118a7bb1?d=mm&r=g" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.fortbendstar.com/users/profile/Landan%20Kuhlmann" rel="author" class="tnt-user-profile-link tnt-user-name">Landan Kuhlmann</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:landan@theleadernews.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul></div>
                        </div>
                    </div>
                </div>
            </article>
                    </div>
                    <script>
                        $('#author-popup-f97faa20-56dc-11eb-b69b-335477e091b2-asset-4de54afa-c434-11ec-a452-07036ac0d637').popover({
                            content: $('#author-popup-f97faa20-56dc-11eb-b69b-335477e091b2-asset-4de54afa-c434-11ec-a452-07036ac0d637-content').html(),
                            container: 'body',
                            html:true,
                            sanitize: false,
                            trigger:'hover',
                            placement:'top',
                            delay:{ show:100, hide:200 }
                        });
                    </script>
                </li>
        
        
            <li class="visible-print">
        <time datetime="2022-04-24T20:09:00-05:00" class="tnt-date asset-date text-muted">
            Apr 24, 2022
        </time></li>
            <li class="hidden-print"><time datetime="2022-04-24T20:09:00-05:00" class="tnt-date asset-date text-muted">Apr 24, 2022</time>
        <span class="text-muted tnt-update-recent">Updated </span>
        <time datetime="2022-04-24T22:35:05-05:00" class="tnt-date tnt-update-recent asset-date text-muted">8 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count comment-counter">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2022-04-24T20:09:00-05:00">
    <meta itemprop="datePublished" content="2022-04-24T20:09:00-05:00">
    <meta itemprop="dateModified" content="2022-04-24T17:35:05-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&via=FortBendStar&url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.fortbendstar.com/tncms/asset/editorial/4de54afa-c434-11ec-a452-07036ac0d637" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BFort%20Bend%20Star%5D%20Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&body=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-b517e84a-c434-11ec-b642-dbe6ebcab48a" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-b517e84a-c434-11ec-b642-dbe6ebcab48a" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1070">
            <meta itemprop="height" content="602">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg"><img
                        src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=400%2C225"
                        srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=150%2C84 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=200%2C113 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=225%2C127 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=300%2C169 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=400%2C225 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=540%2C304 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=640%2C360 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=750%2C422 750w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=990%2C557 990w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=1035%2C582 1035w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/b/51/b517e84a-c434-11ec-b642-dbe6ebcab48a/6265f582a22cd.image.jpg?resize=1070%2C602 1200w"
                        sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                        
                        width="1070"
                        height="602"
                        alt="Marshall track"
                        class="img-responsive full tnt-restrict-img-b517e84a-c434-11ec-b642-dbe6ebcab48a default" />
            </div><style>
                .tnt-restrict-img-b517e84a-c434-11ec-b642-dbe6ebcab48a {
                    max-width: 1070px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                        
                            
                                <span class="credit">
                                    <span  class="tnt-byline">Contributed photo</span>
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="4de54afa-c434-11ec-a452-07036ac0d637">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                            
                            <div id="share-left-affix" class="share-container content-left hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&via=FortBendStar&url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.fortbendstar.com/tncms/asset/editorial/4de54afa-c434-11ec-a452-07036ac0d637" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BFort%20Bend%20Star%5D%20Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&body=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-4de54afa-c434-11ec-a452-07036ac0d637-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="4de54afa-c434-11ec-a452-07036ac0d637" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="4de54afa-c434-11ec-a452-07036ac0d637" class="save-list-4de54afa-c434-11ec-a452-07036ac0d637-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="4de54afa-c434-11ec-a452-07036ac0d637" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                            <script>
                                $(window).load(function() {
                                    window.setTimeout(affixShare, 2000);
                                    function affixShare() {
                                        var sHeight = $('#share-left-affix').outerHeight(true);
                                        var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                        var sTop = $('#share-left-affix').offset().top - 50;
                                        var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + cHeight - 50);
                                        if(cHeight > sHeight) {
                                            $('#share-left-affix').affix({
                                                offset: { top: sTop, bottom: sBottom }
                                            });
                                        }
                                    }
                                });
                                $(window).resize(function() {
                                    var sHeight = $('#share-left-affix').outerHeight(true);
                                    var cHeight = $('#share-left-affix').parent().outerHeight(true);
                                    var sTop = $('#share-left-affix').offset().top - 50;
                                    var sBottom = $(document).height() - ($('#share-left-affix').parent().offset().top + $('#share-left-affix').parent().outerHeight(true) - 50);
                                    if(cHeight > sHeight) {
                                        $('#share-left-affix').data('bs.affix').options.offset.top = sTop;
                                        $('#share-left-affix').data('bs.affix').options.offset.bottom = sBottom;
                                    }
                                });
                            </script>
                            
                        
                        <div class="asset-body has-fixed-share" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above visible-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&via=FortBendStar&url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.fortbendstar.com/tncms/asset/editorial/4de54afa-c434-11ec-a452-07036ac0d637" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BFort%20Bend%20Star%5D%20Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&body=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-4de54afa-c434-11ec-a452-07036ac0d637-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="4de54afa-c434-11ec-a452-07036ac0d637" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="4de54afa-c434-11ec-a452-07036ac0d637" class="save-list-4de54afa-c434-11ec-a452-07036ac0d637-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="4de54afa-c434-11ec-a452-07036ac0d637" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div id="article-body"  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p>The Marshall Buffalos’ track team has a recent, but extensive, history of dominance in the region and state. Its boys’ team has taken home the Class 5A state championship five of the last seven seasons, while its girls’ team is on the heels of its first state crown.</p><p>Both won the title last year, and have shown no let-up as they push their way back toward the top. On the heels of sweeping the District 24-5A district titles, the Buffalos and Lady Buffalos did the same at last week’s area track meet.</p><p>The boys’ team cruised to the crown, finishing with 136 total points in beating out Angleton (108 points) while each of its 400, 800, and 1600 relay teams easily cruised to victory.</p><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>Gerard Holmes ran a leg on both the 400 and 1600 relay, and was also the 200 area champion with a time of 20.76 in the final. Meanwhile, Arveyon Davis qualified in the 100 and 300 hurdles as well as the long jump while running on the 1600 relay. Sprinter Chris Brinkley was the area champion in both the 110 and 300 hurdles.</p><p>On the girls’ side, the Lady Buffalos’ quest was a little tougher, though they still came out on top. Their 146 total points narrowly beat out Foster (138 points) for the crown, and all three relay teams mirrored their boys’ counterparts in winning the area title.</p><p>Desirae Roberts was a regional qualifier in the 100 and 300 hurdles while also running the anchor leg of the 1600 relay, and Tairah Johnson won the 100 hurdles final with a time of 13.74 seconds. Cesley Williams won the 400 in 56.79, while Brittney Green was the 200 area champion with a final time of 24.47 seconds.</p><p><strong>Class 6A</strong></p><p>Not to be outdone by their Missouri City counterparts, the Ridge Point boys’ track team was the champion of the 6A meet. They racked up 136 points, beating out Katy Seven Lakes (121) and Katy Tompkins (106) for the crown.</p><p>Individually, Cayden Broadnax was the 200 champion after running the final in 21.78 seconds. Broadnax also ran a leg on the Panthers’ regional qualifying teams in the 400 and 800 relay, which along with its 1600 relay team were the area champions. Mason Dossett was also the 110 hurdle champion with a time of 13.66 in the final.</p><p>Damilare Olukosi took home the area crown for Travis in the boys’ triple jump with a best jump of 49-1.</p><p>On the girls’ side, George Ranch finished second in the area meet with 94 overall points. Sophia Nguyen was the area champion in the 1600, finishing in 5:08.67 to claim the crown. The Lady Longhorns also had their 400, 800, and 1600 relay teams finish second to reach the regional meet.</p><p>The Elkins girls 1600 relay team of Faith Holman, Taylor Jackson, Emillia Gill, and Mfoniso Andrew took home the area title after a 3:53.97 in the final. Andrew also qualified in the 100 and 400, while Sydney Freeman was the discus throw area champion with a throw of 125-09.</p><p>Bush has two girls’ relay teams headed to the regional meet as area champions. The 400 relay team of Raylen Russell, Rachel Joseph, Christina Pleasant and Amariya Hardeman ran a 45.10 in the final, while the 800 relay of Demeri Duplechain, Russell, Pleasant, and Hardeman finished in 1:39.76.</p><p>Briana Bejar (18-5.5) and Grace Murphy (18-5.25) went 1-2 in the girls’ long jump for the Travis Lady Tigers.</p><p><strong>Class 4A</strong></p><p>At the Class 4A area meet, Amber Butler stole the show for the Stafford Lady Spartans on the girls’ side. The junior was the area champion in the 100 meters (12.13 seconds) as well as the 200 (25.55), and she also ran the second leg for Stafford’s regional qualifying 400 relay team. Mackenzie Catalon and Tori Williams both ran a leg of the Lady Spartans’ 400, 800, and 1600 relay teams, with Catalon anchoring the 400 relay and Williams running the anchor leg of the 1600 relay.</p><p>On the boys’ side, Chris Gardener-Holland ran the first leg for each of the Spartans’ three qualifying relay teams, including the 800 relay team that was the area champion after running a 1:30.08 in the final. That team also included Chase Williams, Jordan Barrett and Caleb Jones. Quardale Pratt was the area champion in the shot put with a distance of 57-02, while Andrew Huff won the area title in the discus throw after a distance of 175-10. Koi Wedderburn is advancing to regionals in two events, including a first-place long jump finish.</p><p>A full list of the area’s regional qualifiers can be seen below:</p><p><strong>Class 6A</strong></p><p><strong>Austin</strong></p><p><strong>Girls</strong></p><p>Jade Harris – 100 hurdles (14.54 seconds; fourth)</p><p>Gabrielle Johnson – High jump (cleared 5-04; third)</p><p><strong>George Ranch</strong></p><p><strong>Girls</strong></p><p>400 relay – Samantha Smith, A’Marie Khan, Journie Franklin, Chiemela Azuike (48.15; second)</p><p>800 relay – A’Marie Khan, Journie Franklin, Kalen Goodman, Chielmela Azuike (1:42.11; second)</p><p>1600 relay – Kalen Goodman, Ava Curtis, Journie Franklin, Madi Gentles (3:58,27; second)</p><p>Sophia Nguyen – 1600 (5:08.67; first) and 3200 (11:43.18; second)</p><p>Ava Curtis – 800 (2:22.10; third)</p><p>Journie Franklin – Long Jump (17-10.5; third)</p><p><strong>Boys</strong></p><p>Shane Gardner – 110 hurdles (14.03; second)</p><p>Ifeoluwa Famogun – 300 hurdles (38.35; second)</p><p>Kyle Kiser – Triple Jump (48-01; second)</p><p>Michael Menely – High Jump (cleared 6-04; second)</p><p>Kaleb Kiser – High Jump (cleared 6-04, fourth) and Triple Jump (47-2.5; fourth)</p><p>Luke Ingelmo – Pole vault (cleared 13-6; fourth)</p><p><strong>Elkins</strong></p><p><strong>Girls</strong></p><p>1600 relay – Faith Holman, Taylor Jackson, Emillia Gill, Mfoniso Andrew (3:53.97; first)</p><p>Mfoniso Andrew – 100 (11.78; fourth place) and 400 (54.17; second place)</p><p>Taylor Jackson – 200 (25.05; third place)</p><p>Sydney Freeman – Women’s Discus throw (125-09; first place)</p><p>Kaylan Woodrow – Women’s Discus throw (117-07; fourth place)</p><p><strong>Travis</strong></p><p><strong>Girls</strong></p><p>400 relay – Miya Greer, Jessica Ogunlade, Jasmine Mayes, Zian Lewis (48.27; fourth)</p><p>800 relay – Miya Greer, Zian Lewis, Jasmine Mayes, Jessica Ogunlade (1:42.82; third)</p><p>Brianna Bejar – Long Jump (18-5.5; first)</p><p>Grace Murphy – Long Jump (18-5.25; second)</p><p><strong>Boys</strong></p><p>1600 relay – Aaron Mendiola, Dominic Njoku, Gabriel Van Wyk, Javaris Bonner (3:21.33; third)</p><p>Israel Akinlabi – 100 (10.72; third)</p><p>Damilare Olukosi – Triple Jump (49-1; first)</p><p><strong>Ridge Point</strong></p><p><strong>Girls</strong></p><p>Kylah Woods – 200 (25.12; fourth)</p><p><strong>Boys</strong></p><p>400 relay – Karson Gordon, Cayden Broadnax, Kerien Charlo, Bert Emanuel Jr. (40.88; first)</p><p>800 relay – Kerien Charlo, Bert Emanuel Jr., Ashton Bethel-Roman, Cayden Broadnax (1:26.41; first)</p><p>1600 relay – Ethan Ellis, Jaden Garner, Terrance Howard, Antoine Thomas (3:19.06; first)</p><p>Kerien Charlo – 100 (10.76; fourth)</p><p>Cayden Broadnax – 200 (21.78; first)</p><p>Xavier Mandiola – 200 (21.85; second)</p><p>Bert Emanuel Jr. – 200 (22.01; third)</p><p>Terrance Howard – 400 (48.75; second)</p><p>Jaden Garner – 800 (1:59.67; third)</p><p>Mason Dossett – 110 hurdles (13.66; first)</p><p>Parker Brannon – Pole vault (cleared 14-00.00; third)</p><p>Karson Gordon – Triple Jump (48-01; third)</p><p><strong>Bush</strong></p><p><strong>Girls</strong></p><p>400 relay – Raylen Russell, Rachel Joseph, Christina Pleasant, Amariya Hardeman (45.40; first)</p><p>800 relay – Demeri Duplechain, Raylen Russell, Christina Pleasant, Amariya Hardeman (1:39.76; first)</p><p>Amariya Hardeman – 200 (24.70; second)</p><p>Lauren Moore – 300 hurdles (45.29; second)</p><p>Rachel Joseph – 400 (55.15; third)</p><p><strong>Boys</strong></p><p>800 relay – Caidan Hackley, Osayi Ogbeiwi, Hassan Sunmonu, Jedidiah Udunna (1:28.36; fourth)</p><p><strong>Class 5A</strong></p><p><strong>Marshall</strong></p><p><strong>Girls</strong></p><p>400 relay – Cesley Williams, Brittney Green, Tyeler Moore, Dior Williams (46.75; first)</p><p>800 relay – Genesis Griffin, Tyeler Moore, Janai Williams, Tairah Johnson (1:40.78; first)</p><p>1600 relay – Brittney Green, Cesley Williams, Brianna Brinkley, Desirae Roberts (3:56.81; first)</p><p>Brittney Green – 200 (24.47; first)</p><p>Cesley Williams – 400 (56.79; first)</p><p>Brianna Brinkley – 400 (59.48; third)</p><p>Genesis Griffin – Long Jump (18-11; first)</p><p>Tairah Johnson – 100 hurdles (13.74; first) and Long Jump (18-3; second)</p><p>Desirae Roberts – 100 hurdles (14:39; second) and 300 hurdles (45.08; first)</p><p>Dior Williams –100 hurdles (14.61; third)</p><p><strong>Boys</strong></p><p>400 relay – Kameron Williams, Michael Patterson, Gerard Holmes, Jonathan Howard (40.35; first)</p><p>800 relay – Kameron Williams, Michael Patterson, Jonathan Howard, William Mitchell (1:24.58; first)</p><p>1600 relay – Gerard Holmes, Chris Brinkley, Arveyon Davis, Mason Roseboro (3:15.63; first)</p><p>Troy Dixon – 100 (10.58; third)</p><p>Gerard Holmes – 200 (20.76; first)</p><p>Jonathan Howard – 200 (21.01; second)</p><p>Mason Roseboro – 400 (50.44; third)</p><p>Chris Brinkley – 110 hurdles (14.24; first) and 300 hurdles (37.15; first)</p><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"><div id="tncms-block-1040499" class="tncms-block"><script>
document.addEventListener("DOMContentLoaded",function(){
var pathvar = "https://fortbendstar.com" + window.location.pathname;
document.getElementById("outbrain_widget_0").setAttribute("data-src", pathvar);
}
);
</script><div class="OUTBRAIN" data-src="https://fortbendstar.com" data-widget-id="GS_4"></div>
<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script></div></div><p>Arveyon Davis – 110 hurdles (15.07; fourth), 300 hurdles (38.64; second), and long jump (22-3.75; second)</p><p>Jy’Adrian Worthan – Long jump (22-3.5; third)</p><p><strong>Hightower</strong></p><p><strong>Girls</strong></p><p>400 relay – Kennedy Jackson, Kendra Kamanu, Anaya Simon, Alexia Morgan (50.17; fourth)</p><p>800 relay – Kendra Kamanu, Anaya Simon, Alexia Morgan, Kylin Scott (1:46.62; fourth)</p><p>1600 relay – Madison Bob, Cayla Anthony, Kylin Scott, Mya Peters (4:01.20; second)</p><p>Anaya Simon – 100 (12.57; third)</p><p>Mya Peters – 400 (59.53; fourth) and 800 (2:27.10; second)</p><p>Cayla Anthony – 800 (2:28.40; third)</p><p>Khylin Scott – 300 hurdles (47.98; second)</p><p>Xoe Alo – Shot put (33-6; second)</p><p><strong>Boys</strong></p><p>1600 relay – Jaedyn Ferguson, Joshua Sims-Waddy, Aaron White, Santana Wilson (3:19.93; second)</p><p>Jamarion Ferguson – 100 (10.74; fourth) and 200 (21.86; fourth)</p><p>Joshua Sims-Waddy – 400 (48.77; first)</p><p>Santana Wilson – 400 (49.62; second)</p><p>Kurtis Nickerson – 3200 (11:06.83; fourth)</p><p>Trevian Hanner – 110 hurdles (14.98; third)</p><p>Jalen Davis – 300 hurdles (42.56; fourth)</p><p>Rickey McGraw – High jump (6-3; first)</p><p><strong>Willowridge</strong></p><p><strong>Girls</strong></p><p>Illona Gabaut-Diziere – 800 (2:28.68; fourth)</p><p><strong>Foster</strong></p><p><strong>Girls</strong></p><p>400 relay – Hiqmat Marshal-Sulayman, Muna Osagie, Divine Ozomma, Ogechukwu Nwajiaku (50.15; third)</p><p>800 relay – Kendal Brown, Divine Ozomma, Anaya Ervin, Hiqmat Marshal-Sulayman (1:45.78; second)</p><p>1600 relay – Anaya Ervin, Skyla Riedel, Kendal Brown, Samantha Doherty (4:12.68; third)</p><p>Kendal Brown – 100 (12.55; second) and pole vault (7-0; fourth)</p><p>Kayleigh Bowie – 200 (24.80; third) and 400 (58.74; second)</p><p>Kamryn Williams – 800 (2:25.66; first) and 1600 (5:29.57; first)</p><p>Kaitlyn Walsh – 1600 (5:37.04; second)</p><p>Grace Gholson – 1600 (5:38.42; third) and 3200 (12:17.85; first)</p><p>Anaya Ervin – 300 hurdles (50.11; third) and high jump (4-10; fourth)</p><p>Karleigh Niles – Pole vault (9-6; first)</p><p>Caroline Cavazos – Pole vault (9-6; second)</p><p><strong>Boys</strong></p><p>400 relay – Cedric Adjet, Quenton Joseph; Kendal Stewart, Eli England (41.98; third)</p><p>Eli England – 100 (10.47; first) and 200 (21.62; third)</p><p>Caleb Anthony – 800 (1:57.51; first)</p><p>Grant Currier – 1600 (4:47.55; third)</p><p>William Davis – 3200 (10:28.41; second)</p><p>Larrian Robinson – Shot put (47-7.75; first)</p><p>Jake Maynard – Pole vault (11-0; third)</p><p><strong>Fulshear</strong></p><p><strong>Girls</strong></p><p>400 relay – Morijah Terry, Chizobam Okafor, Anisa Odom, Belicia Delk (49.19; second)</p><p>800 relay – Morijah Terry, Angel Osaghae, Chizobam Okafor, Belicia Delk (1:46.41; third)</p><p>1600 relay – Kamoria Reese, Angle Osaghe, Addie Nowak, Belicia Delk (4:16.05; fourth)</p><p>Morijah Terry – 100 (12.78; fourth)</p><p>Chizobam Okafor – 200 (24.48; second) and triple jump (36-8.75; third)</p><p>Ami Quiroz – 1600 (5:46.59; fourth) and 3200 (12:30.67; second)</p><p>Aspen Boyd – 3200 (14:43.27; fourth)</p><p>Anisa Odom – 100 hurdles (16:31; fourth), 300 hurdles (51.00; fourth), long jump (16-3.75; fourth), triple jump (34-5; fourth)</p><p>Kamoria Reese – High jump (4-10; third)</p><p>Tylie Michal – Pole vault (8-0; third)</p><p><strong>Boys</strong></p><p>Tyler Browning – 800 (1:59.44; second)</p><p>Zakary Sury – 800 (2:02.70; third) and 1600 (4:37.04; first)</p><p>Celso Pacheco – 1600 (4:42.31; second) and 3200 (10:21.26; first)</p><p>Jacobi Adelizzi – 3200 (10:51.55; third)</p><p>Jacob Sanders – Shot put (45-3.5; second)</p><p>Blain Evatt – Discus (164-1; first)</p><p>T.J. Ojo – Triple jump (40-3.5; fourth)</p><p>Ben McGown – Pole vault (15-0; first)</p><p><strong>Rosenberg Terry</strong></p><p><strong>Girls</strong></p><p>Alicia Martinez – 3200 (12:54.22; third)</p><p>Alexia Washington – Long jump (17-4.5; third) and triple jump (38-9; first)</p><p>Ekbom Mbarikit – High jump (5-2; first)</p><p><strong>Boys</strong></p><p>400 relay – Trumaine Mitchell, Wilson Lightfoot, Devin Wilkerson, Alphonso Brown (41.22; second)</p><p>800 relay – Trumaine Mitchell, Wilson Lightfoot, Alphonso Brown, Devin Wilkerson (1:26.32; second)</p><p>1600 relay – Trumaine Mitchell, Alphonso Brown, Devin Wilkerson, Anthony Axel (3:25.61; fourth)</p><p>Roel Guajardo – Shot put (44-7; third)</p><p>Anthony Axel – High jump (6-2; fourth)</p><p><strong>Lamar Consolidated</strong></p><p><strong>Girls</strong></p><p>Ayanna Johnson – 200 (24.86; fourth)</p><p>Bria Lawson – Shot put (32-3.75; fourth)</p><p>Malaijah Wright- Discus (96-8; third)</p><p>Karlyn Stavinoha – High jump (4-11; second)</p><p>Class 4A</p><p>Stafford</p><p>Girls</p><p>400-meter relay – Tori Williams, Amber Butler, Paige Lewis, Mackenzie Catalon (49.56 seconds, second place)</p><p>800 relay – Tori Williams, Mackenzie Catalon, Paige Lewis, Madison Robinson (1:49.38; third place)</p><p>1600 relay – Mackenzie Catalon, Paige Lewis, Marissa Miller, Tori Williams (4:18.05; fourth place)</p><p>Amber Butler – 100 meters (12.13; first place) and 200 meters (25.55; first place)</p><p>Boys</p><p>400-meter relay – Chris Gardener-Holland, Caleb Jones, Jordan Barrett, Jamaal Wiley (43.13; second place)</p><p>800 relay – Chris Gardener-Holland, Chase Williams, Jordan Barrett, Caleb Jones (1:30.08; first place)</p><p>1600 relay – Chris Gardener-Holland, Chase Williams, Weldon Moffett, Jeremiah Sanders (3:33.47; third place)</p><p>Caleb Jones – 100 meters (10.79; second place)</p><p>Jeremiah Sanders – 400 meters (52.86; fourth place)</p><p>Bradley Lowman – 300 hurdles (42.79; third place)</p><p>Quardale Pratt – Shot Put (57-02; first place)</p><p>Braylon Rideau – Shot Put (51-8.25; third place)</p><p>Andrew Huff – Shot Put (51-2.5; fourth place) and Discus Throw (175-10; first place)</p><p>Koi Wedderburn – Long Jump (22-4.5; first place) and Triple Jump (43-6.75; fourth place)</p><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&via=FortBendStar&url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.fortbendstar.com/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.fortbendstar.com/tncms/asset/editorial/4de54afa-c434-11ec-a452-07036ac0d637" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BFort%20Bend%20Star%5D%20Buffs%20boys%2C%20girls%20thunder%20through%20area%20meets&body=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4de54afa-c434-11ec-a452-07036ac0d637"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-4de54afa-c434-11ec-a452-07036ac0d637-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="4de54afa-c434-11ec-a452-07036ac0d637" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="4de54afa-c434-11ec-a452-07036ac0d637" class="save-list-4de54afa-c434-11ec-a452-07036ac0d637-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="4de54afa-c434-11ec-a452-07036ac0d637" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    
                        
                            <div class="asset-author">
                                <article class="clearfix card author  card-author-f97faa20-56dc-11eb-b69b-335477e091b2">
                <div class="card-container">
                    <div class="media-list">
                        <div class="media">
                            
                                <div class="avatar-box pull-left hidden-print">
                                    <a href="https://www.fortbendstar.com/users/profile/Landan%20Kuhlmann" class="tnt-user-profile-link user-profile-link card-image media-object" rel="author">
                                        <img alt="Landan Kuhlmann" src="https://secure.gravatar.com/avatar/303468b57b38acf6e3640ece118a7bb1?d=mm&r=g" width="200" height="200" loading="lazy" class="img-responsive lazyload tnt-user-avatar" />
                                    </a>
                                </div>
                            

                            <div class="media-body ">
                                <h4 class="media-heading">
                                    <a href="https://www.fortbendstar.com/users/profile/Landan%20Kuhlmann" rel="author" class="tnt-user-profile-link tnt-user-name">Landan Kuhlmann</a>
                                </h4>
    
        <ul class="list-inline social-links hidden-print">
            <li>
                <a href="mailto:landan@theleadernews.com" title="Email">
                    <span class="sr-only">Author email</span>
                    <span class="tnt-stack">
                        
                        <i class="fas tnt-envelope tnt-stack-1x"></i>
                    </span>
                </a>
            </li>
    </ul><div class="followed-notify-link hidden-print"><button id="follow-author-f97faa20-56dc-11eb-b69b-335477e091b2" class="followed-notify-btn btn btn-success btn-sm" disabled data-params="?a=f97faa20-56dc-11eb-b69b-335477e091b2&amp;s=start_time&amp;sd=desc" data-subject="Landan Kuhlmann" data-description="Whenever Landan Kuhlmann posts new content, you'll get an email delivered to your inbox with a link." data-name="Landan Kuhlmann notification" data-author-id="f97faa20-56dc-11eb-b69b-335477e091b2" data-user-url="https://www.fortbendstar.com/users/">
        <i class="fas tnt-star"></i> Follow Landan Kuhlmann
    </button><template id="follow-this-modal-logged-in">
            <div class="modal-dialog">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Get email notifications on {{subject}} daily!</h4>
                    </div>
                    <div class="modal-body">
                        <div class="alert alert-success" style="display:none;">
                            Your notification has been saved.
                        </div>
                        <div class="alert alert-danger" style="display:none;">
                            There was a problem saving your notification.
                        </div>
                        <p class="notification-description">{{description}}</p>
                        <p>Email notifications are only sent once a day, and only if there are new matching items.</p>
                        <form id="follow-notify-form" class="follow-notify-form" action="{{action}}" method="post">
                            <input class="input-notification-name" type="hidden" name="title" value="{{title}}">
                            <div class="row">
                                <div class="col-sm-6">
                                    <button class="btn btn-success btn-block follow-btn" >
                                        <i class="fas tnt-spinner tnt-pulse" style="display:none;"></i> Save
                                    </button>
                                </div>
                                <div class="col-sm-6">
                                    <a class="btn btn-default btn-block" href="https://www.fortbendstar.com/users/admin/savedsearch/">Manage followed notifications</a>
                                </div>
                            </div>
                        </form>
                    </div>
                </div>
            </div>
        </template>

        <template id="follow-this-modal-logged-out">
            <div class="modal-dialog modal-sm">
                <div class="modal-content">
                    <div class="modal-header">
                        <button class="close" type="button" data-dismiss="modal">
                            <i class="fas tnt-times-circle"></i>
                            <span class="sr-only">Close</span>
                        </button>
                        <h4 class="modal-title">Followed notifications</h4>
                    </div>
                    <div class="modal-body">
                        <div class="user-login padding-bottom">
                            <h4>Please log in to use this feature</h4>
                            <a class="btn btn-block btn-primary" href="https://www.fortbendstar.com/users/login/?referer_url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html" rel="nofollow">Log In</a>
                        </div>
                        <div class="user-signup">
                            <strong>Don't have an account?</strong> <a href="https://www.fortbendstar.com/users/signup/?referer_url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html" rel="nofollow">Sign Up Today</a>
                        </div>
                    </div>
                </div>
            </div>
        </template>

        <div id="follow-this-modal" class="modal fade follow-this-modal">
            <div class="modal-dialog"></div>
        </div></div></div>
                        </div>
                    </div>
                </div>
            </article>
                            </div>
                        
                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1040498" class="tncms-block"><script>
document.addEventListener("DOMContentLoaded",function(){
var pathvar = "https://fortbendstar.com" + window.location.pathname;
document.getElementById("outbrain_widget_1").setAttribute("data-src", pathvar);
}
);
</script><div class="OUTBRAIN" data-src="https://fortbendstar.com" data-widget-id="GS_1"></div>
<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script></div></div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="4de54afa-c434-11ec-a452-07036ac0d637" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="4de54afa-c434-11ec-a452-07036ac0d637" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.fortbendstar.com/users/login/?referer_url=https%3A%2F%2Fwww.fortbendstar.com%2Fsports%2Fbuffs-boys-girls-thunder-through-area-meets%2Farticle_4de54afa-c434-11ec-a452-07036ac0d637.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"><div id="tncms-block-1040606" class="tncms-block"><script>
document.addEventListener("DOMContentLoaded",function(){
var pathvar = "https://fortbendstar.com" + window.location.pathname;
document.getElementById("outbrain_widget_2").setAttribute("data-src", pathvar);
}
);
</script><div class="OUTBRAIN" data-src="https://fortbendstar.com" data-widget-id="AR_1"></div>
<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script></div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-1000704" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1000704" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1000704');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-1040105" class="tncms-block"><p class="text-center">
<a href="https://www.texancredit.com">
<img src="https://www.fortbendstar.com/tncms/media/xs268875/">
</a>
</p>

<p class="text-center">
<a href="https://www.mcelvypartners.com/ignite/">
<img src="https://www.fortbendstar.com/tncms/media/ignite_register/">
</a>
</p>




<p class="text-center">
<a href="https://texasprinters.com/">
<img src="https://www.fortbendstar.com/tncms/media/fbswebsite_printingad_09132021recovered/"></a>
</p></div><div id="tncms-block-1000533" class="tncms-block visible-lg visible-md"><section id="block-1000533" class="block emphasis-h3 dark  " ><div class="clearfix">
    
    <div class="block-title title-1000533 ">
        <div class="block-title-inner">
            <h3>
                
                Recent Headlines
                
            </h3>
        </div>
    </div></div>
    <div class=" card-bg-color"><div class="card-panel panel">
            <div class="panel-body"><ul class="card headline-list bullet-decimal border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/buffs-boys-girls-thunder-through-area-meets/article_4de54afa-c434-11ec-a452-07036ac0d637.html" class="tnt-asset-link" aria-label="Buffs boys, girls thunder through area meets">
        

        
            Buffs boys, girls thunder through area meets</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/foster-no-hitters-highlight-performances-on-diamond/article_2f322402-c0b5-11ec-98f4-aba36a9bfa3a.html" class="tnt-asset-link" aria-label="Foster no-hitters highlight performances on diamond">
        

        
            Foster no-hitters highlight performances on diamond</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/schoolnews/new-fbisd-elementary-school-to-bear-name-of-late-student/article_9fbe1724-bff9-11ec-a4ef-d3199bdeebd9.html" class="tnt-asset-link" aria-label="New FBISD elementary school to bear name of late student">
        

        
            New FBISD elementary school to bear name of late student</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/stafford-boys-ridge-point-girls-fall-in-state-semis/article_afb091d0-bf5d-11ec-8e2c-3f9b6fb27913.html" class="tnt-asset-link" aria-label="Stafford boys, Ridge Point girls fall in state semis">
        

        
            Stafford boys, Ridge Point girls fall in state semis</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/countynews/missouri-city-hires-firm-to-investigate-city-manager/article_654c7374-bf5e-11ec-94ad-6feb5f2bc48b.html" class="tnt-asset-link" aria-label="Missouri City hires firm to investigate city manager">
        

        
            Missouri City hires firm to investigate city manager</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/schoolnews/trustee-two-superintendent-contracts-source-of-smsd-investigation/article_5bbe4a22-bf5d-11ec-8696-a3185ca44710.html" class="tnt-asset-link" aria-label="Trustee: Two superintendent contracts source of SMSD investigation">
        

        
            Trustee: Two superintendent contracts source of SMSD investigation</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/culture/review-lupitas-shows-why-it-is-sugar-land-staple/article_e3e56940-bf6b-11ec-bf69-638f0bb77ab2.html" class="tnt-asset-link" aria-label="Review: Lupitas shows why it is Sugar Land staple">
        

        
            Review: Lupitas shows why it is Sugar Land staple</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/culture/cross-creek-ranch-holding-saturday-arts-market/article_7372f182-bf6b-11ec-bc3f-a3b2c2bcb6d9.html" class="tnt-asset-link" aria-label="Cross Creek Ranch holding Saturday arts market">
        

        
            Cross Creek Ranch holding Saturday arts market</a></span>
        </li></ul></div>
        </div></div></section></div><div id="tncms-block-1000570" class="tncms-block"><section id="block-1000570" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1000570 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-1000570" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-1000570" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-1000570" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-1000570" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-1000570" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/countynews/missouri-city-hires-firm-to-investigate-city-manager/article_654c7374-bf5e-11ec-94ad-6feb5f2bc48b.html">Missouri City hires firm to investigate city manager</a></li><li><a href="/schoolnews/trustee-two-superintendent-contracts-source-of-smsd-investigation/article_5bbe4a22-bf5d-11ec-8696-a3185ca44710.html">Trustee: Two superintendent contracts source of SMSD investigation</a></li><li><a href="/culture/review-lupitas-shows-why-it-is-sugar-land-staple/article_e3e56940-bf6b-11ec-bf69-638f0bb77ab2.html">Review: Lupitas shows why it is Sugar Land staple</a></li><li><a href="/schoolnews/new-fbisd-elementary-school-to-bear-name-of-late-student/article_9fbe1724-bff9-11ec-a4ef-d3199bdeebd9.html">New FBISD elementary school to bear name of late student</a></li><li><a href="/culture/nibbles-and-sips-lazy-dog-expanding-to-stafford/article_154e635a-bf5e-11ec-bbbd-6b6ea6aa5fc8.html">Nibbles and Sips: Lazy Dog expanding to Stafford</a></li><li><a href="/business_real_estate/appraisals-skyrocketing-on-homes-across-fort-bend-county/article_957e13f0-bb43-11ec-8cd9-33b34592a85c.html">Appraisals skyrocketing on homes across Fort Bend County</a></li><li><a href="/health/memorial-hermann-relaxes-many-covid-related-restrictions/article_561321c0-bf5c-11ec-8920-2bf49fa63357.html">Memorial Hermann relaxes many COVID-related restrictions</a></li><li><a href="/countynews/missouri-city-manager-on-administrative-leave/article_dfee9244-b53e-11ec-a00d-a3523aac4ba3.html">Missouri City manager on administrative leave</a></li><li><a href="/culture/cross-creek-ranch-holding-saturday-arts-market/article_7372f182-bf6b-11ec-bc3f-a3b2c2bcb6d9.html">Cross Creek Ranch holding Saturday arts market</a></li><li><a href="/sports/willowridge-alumus-named-school-s-new-football-coach/article_fc8e4ada-bec0-11ec-8cbf-d77edff118a7.html">Willowridge alumus named school’s new football coach</a></li></ul></div>
        
        
            <div id="images-1000570" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/pinoy-gourmet/image_1db5d282-b511-11ec-a08b-5f023180391f.html" class="tnt-asset-link"  aria-label="Pinoy Gourmet">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Pinoy Gourmet"
                            class="img-responsive lazyload full default"
                            width="1247"
                            height="1247"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/1/db/1db5d282-b511-11ec-a08b-5f023180391f/624c8f8956fc5.image.jpg?crop=1247%2C1247%2C0%2C208&resize=1247%2C1247&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ariel-kowalewski/image_576037be-af82-11ec-9f86-278e1b31aa4d.html" class="tnt-asset-link"  aria-label="Ariel Kowalewski">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Ariel Kowalewski"
                            class="img-responsive lazyload full default"
                            width="1168"
                            height="1168"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/5/76/576037be-af82-11ec-9f86-278e1b31aa4d/62433c764f555.image.jpg?crop=1168%2C1168%2C0%2C56&resize=1168%2C1168&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/easter-2/image_4d56323a-bc09-11ec-ba9f-97235939c637.html" class="tnt-asset-link"  aria-label="Easter 2">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Easter 2"
                            class="img-responsive lazyload full default"
                            width="1146"
                            height="1146"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/4/d5/4d56323a-bc09-11ec-ba9f-97235939c637/625840b6e829f.image.jpg?crop=1146%2C1146%2C0%2C331&resize=1146%2C1146&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/ridge-point-state-soccer/image_313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc.html" class="tnt-asset-link"  aria-label="Ridge Point state soccer">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Ridge Point state soccer"
                            class="img-responsive lazyload full default"
                            width="1191"
                            height="1191"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/3/13/313f5f16-ba80-11ec-8e7f-7b6bf6b3c1fc/6255ae94057f6.image.jpg?crop=1191%2C1191%2C274%2C0&resize=1191%2C1191&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/kendron-penson-sr/image_2833b9e0-bec1-11ec-9cfb-b39572e04c58.html" class="tnt-asset-link"  aria-label="Kendron Penson Sr.">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Kendron Penson Sr."
                            class="img-responsive lazyload full default"
                            width="314"
                            height="314"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/2/83/2833b9e0-bec1-11ec-9cfb-b39572e04c58/625cd08398763.image.jpg?resize=150%2C150 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/2/83/2833b9e0-bec1-11ec-9cfb-b39572e04c58/625cd08398763.image.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/2/83/2833b9e0-bec1-11ec-9cfb-b39572e04c58/625cd08398763.image.jpg?resize=225%2C225 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/2/83/2833b9e0-bec1-11ec-9cfb-b39572e04c58/625cd08398763.image.jpg?resize=300%2C300 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/2/83/2833b9e0-bec1-11ec-9cfb-b39572e04c58/625cd08398763.image.jpg?resize=314%2C314 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/dream-league-3/image_6dd82812-b464-11ec-b165-17c67f88f3ca.html" class="tnt-asset-link"  aria-label="Dream League 3">
                
                
                
                
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Dream League 3"
                            class="img-responsive lazyload full default"
                            width="1175"
                            height="1175"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=150%2C150&order=crop%2Cresize 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=225%2C225&order=crop%2Cresize 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/editorial/6/dd/6dd82812-b464-11ec-b165-17c67f88f3ca/624b6dbf994d8.image.jpg?crop=1175%2C1175%2C294%2C0&resize=1175%2C1175&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-1000570" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><p class="no-results text-muted">Sorry, there are no recent results for popular videos.</p></div>
        
        
        
        
            <div id="commented-1000570" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/schoolnews/trustee-two-superintendent-contracts-source-of-smsd-investigation/article_5bbe4a22-bf5d-11ec-8696-a3185ca44710.html">Trustee: Two superintendent contracts source of SMSD investigation</a> (1)</li><li><a href="/business_real_estate/appraisals-skyrocketing-on-homes-across-fort-bend-county/article_957e13f0-bb43-11ec-8cd9-33b34592a85c.html">Appraisals skyrocketing on homes across Fort Bend County</a> (1)</li><li><a href="/sports/local-special-needs-baseball-league-back-in-swing/article_caf942c0-b463-11ec-b3a0-9bca972b7cf7.html">Local special needs baseball league back in swing</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-1000596" class="tncms-block"></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"><div id="tncms-block-1040213" class="tncms-block"><script>
document.addEventListener("DOMContentLoaded",function(){
var pathvar = "https://fortbendstar.com" + window.location.pathname;
document.getElementById("outbrain_widget_3").setAttribute("data-src", pathvar);
}
);
</script><div class="OUTBRAIN" data-src="https://fortbendstar.com" data-widget-id="GS_6"></div>
<script type="text/javascript" async="async" src="http://widgets.outbrain.com/outbrain.js"></script></div></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1000587" class="tncms-block"></div><div id="tncms-block-1027930" class="tncms-block"><section id="block-1027930" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1027930 ">
        <div class="block-title-inner">
            <h3>
                
                Our Latest Paper
                
            </h3>
        </div>
    </div></div><div class="block"><a href="https:////issuu.com/sugarlandnewcomerguide.com/docs/fortbend_0420_all" rel="nofollow noopener" target="_blank" aria-label="Our Latest Paper">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/2efd0b1c-bff9-11ec-8373-23f0909ad69e.jpg?resize=150%2C295 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/2efd0b1c-bff9-11ec-8373-23f0909ad69e.jpg?resize=200%2C394 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/2efd0b1c-bff9-11ec-8373-23f0909ad69e.jpg?resize=225%2C443 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/2efd0b1c-bff9-11ec-8373-23f0909ad69e.jpg?resize=300%2C591 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/2efd0b1c-bff9-11ec-8373-23f0909ad69e.jpg 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="317"
                height="624"
                alt="Our Latest Paper"
                ></a></div></section></div><div id="tncms-block-1302226" class="tncms-block"><p class="text-center">
<a href="https://www.mcelvypartners.com/ignite/">
<img src="https://www.fortbendstar.com/tncms/media/ignite_vendor/">
</a>
</p></div><div id="tncms-block-1033033" class="tncms-block"><section id="block-1033033" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1033033 ">
        <div class="block-title-inner">
            <h3>
                
                Latest Fort Bend Business Journal
                
            </h3>
        </div>
    </div></div><div class="block"><a href="https://issuu.com/sugarlandnewcomerguide.com/docs/134464_ft_bend_business_journal_all" rel="nofollow noopener" target="_blank" aria-label="Latest Fort Bend Business Journal">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/dab2ed80-b542-11ec-a0a9-033bd958eaa0.jpg?resize=150%2C192 150w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/dab2ed80-b542-11ec-a0a9-033bd958eaa0.jpg?resize=200%2C256 200w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/dab2ed80-b542-11ec-a0a9-033bd958eaa0.jpg?resize=225%2C288 225w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/dab2ed80-b542-11ec-a0a9-033bd958eaa0.jpg?resize=300%2C384 300w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/dab2ed80-b542-11ec-a0a9-033bd958eaa0.jpg?resize=400%2C512 400w, https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/custom/image/dab2ed80-b542-11ec-a0a9-033bd958eaa0.jpg 540w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="488"
                height="625"
                alt="Latest Fort Bend Business Journal"
                ></a></div></section></div><div id="tncms-block-1040067" class="tncms-block"><p class="text-center"><a href="https://issuu.com/sugarlandnewcomerguide.com/docs/">
<img src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/content/tncms/assets/v3/media/0/f3/0f3d9d6a-a866-11eb-b724-1f2f5d6ca151/6089cf1a12c90.image.jpg"></a></p></div><div id="tncms-block-1000550" class="tncms-block"></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1000590" class="tncms-block"><section id="block-1000590" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1000590 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-community"  href="/community/"  tabindex="0" >
                    <span class="nav-label ">Community</span>
                </a></li><li>
                <a class="nav-link    tnt-section-county-news"  href="/countynews/"  tabindex="0" >
                    <span class="nav-label ">County News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-business-real-estate"  href="/business_real_estate/"  tabindex="0" >
                    <span class="nav-label ">Business & Real Estate</span>
                </a></li><li>
                <a class="nav-link    tnt-section-culture"  href="/culture/"  tabindex="0" >
                    <span class="nav-label ">Culture</span>
                </a></li><li>
                <a class="nav-link    tnt-section-local-events"  href="/local-events/"  tabindex="0" >
                    <span class="nav-label ">Local Events</span>
                </a></li><li>
                <a class="nav-link    tnt-section-school-news"  href="/schoolnews/"  tabindex="0" >
                    <span class="nav-label ">School News</span>
                </a></li><li>
                <a class="nav-link    tnt-section-health"  href="/health/"  tabindex="0" >
                    <span class="nav-label ">Health</span>
                </a></li><li>
                <a class="nav-link    tnt-section-sports"  href="/sports"  tabindex="0" >
                    <span class="nav-label ">Sports</span>
                </a></li><li>
                <a class="nav-link    tnt-section-multimedia"  href="/multimedia/"  tabindex="0" >
                    <span class="nav-label ">Multimedia</span>
                </a></li><li>
                <a class="nav-link    tnt-section-online-features"  href="/online_features"  tabindex="0" >
                    <span class="nav-label ">Online Features</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1000561" class="tncms-block"><section id="block-1000561" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1000561 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link    tnt-section-submission-forms"  href="/site/forms"  tabindex="0" >
                    <span class="nav-label ">Submission Forms</span>
                </a></li><li>
                <a class="nav-link    tnt-section-email-alerts"  href="/users/admin/mailinglist"  tabindex="0" >
                    <span class="nav-label ">Email Alerts</span>
                </a></li><li>
                <a class="nav-link    tnt-section-search"  href="/search"  tabindex="0" >
                    <span class="nav-label ">Search</span>
                </a></li><li>
                <a class="nav-link    tnt-section-weather"  href="/weather"  tabindex="0" >
                    <span class="nav-label ">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1000592" class="tncms-block"><section id="block-1000592" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1000592 ">
        <div class="block-title-inner">
            <h4>
                
                Fort Bend Star
                
            </h4>
        </div>
    </div></div><address>
    <strong>FortBendStar.com</strong><br>
    14100 Southwest Fwy. Ste. 230 <br>
    Sugar Land, TX  77478
    <br>
    
        <strong>Phone:</strong> 281-690-4200<br>
        <strong>Email:</strong> <a href="mailto:editor@fortbendstar.com">editor@fortbendstar.com</a><br>
    
</address></section></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1000565" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1000565"><div class="col-md-7"><small>&copy; Copyright 2022 <a href="/">Fort Bend Star</a>, 14100 Southwest Fwy. Ste. 230  Sugar Land, TX</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("4de54afa-c434-11ec-a452-07036ac0d637")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ dataLayer.push({
            'tncms.asset.sections': ["sports"],
            'tncms.asset.flags': [""],
            'tncms.asset.keywords': [""]
        }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/fortbendstar.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ (function(d) {
        
        var form = d.getElementById('site-search-1000597'),
            query_input = d.getElementById('site-search-1000597-term'),
            search_dropdown = d.getElementById('site-search-1000597-dropdown');
        
        /** Input focus */
        try {
            search_dropdown.onmouseenter = function(){
                setTimeout(function(){
                    query_input.focus();
                }, 700);
            };
        } catch (error) { 
            // No dropdown behavior
        }
        
        /** Submit handler */
        form.onsubmit = function(){
            // Filter query
            var elem = document.querySelector("#site-search-1000597 input[name=q]"),
        sQueryFiltered = elem.value.replace(/\?/g, '');
    elem.value = sQueryFiltered;
    
            // No submit if empty input
            if( query_input.val() ){
                return true;
            } else{
                return false;
            }
        };})(document); /*]]>*/</script>
<script>/*<![CDATA[*/ function articleShareSticky(){
                setTimeout(function(){
                    var sMainTop = document.querySelector('#main-body-container').offsetTop,
                        oNavBar = document.querySelector('#site-navbar-container');
                    if (sMainTop < window.scrollY){
                        oNavBar.classList.add('article-share')
                    } else {
                        oNavBar.classList.remove('article-share')
                    }
                }, 150)
            }
            document.addEventListener('scroll', articleShareSticky); /*]]>*/</script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script></body>
</html>